Click or drag to resize

Result Enumeration

Defines enumerated constant values for several command result types.

Namespace:  Rhino.Commands
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public enum Result
Members
  Member nameValueDescription
Success0Command worked.
Cancel1User canceled command.
Nothing2Command did nothing but cancel was not pressed.
Failure3Command failed (bad input, computational problem, etc.)
UnknownCommand4Command not found (user probably had a typo in command name).
CancelModelessDialog5Commands canceled and modeless dialog.
ExitRhino268435455exit RhinoCommon.
See Also