Click or drag to resize

TransformCommand Class

[Missing <summary> documentation for "T:Rhino.Commands.TransformCommand"]

Inheritance Hierarchy

Namespace:  Rhino.Commands
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public abstract class TransformCommand : Command

The TransformCommand type exposes the following members.

Constructors
  NameDescription
Protected methodTransformCommand
Initializes a new instance of the TransformCommand class
Top
Properties
  NameDescription
Top
Methods
  NameDescription
Protected methodDuplicateObjects
Protected methodReplayHistory
Repeats an operation of a command.

In order to make this function work, you will likely need to grab the Result property that gives the list of input objects. Then, you will be able to replace these inputs by using one of the UpdateToX() methods of the ReplayHistoryResult.

You should NOT use any document AddX() or ReplaceX() functions, as they will break history.
Protected methodResetGrips
Sets dynamic grip locations back to starting grip locations. This makes things like the Copy command work when grips are "copied".
Protected methodSelectObjects(String, TransformObjectList)
Selects objects within the command.
Protected methodSelectObjects(String, ObjectType, TransformObjectList)
Selects objects within the command.
Protected methodTransformObjects
Top
See Also