Click or drag to resize

TransformCommandSelectObjects Method (String, ObjectType, TransformObjectList)

Selects objects within the command.

Namespace:  Rhino.Commands
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
protected Result SelectObjects(
	string prompt,
	ObjectType filter,
	TransformObjectList list
)

Parameters

prompt
Type: SystemString
The selection prompt.
filter
Type: Rhino.DocObjectsObjectType
Geometry filter to limit selection. Use function above if you do not need specific types.
list
Type: Rhino.CollectionsTransformObjectList
A list of objects to transform. This is a special list type.

Return Value

Type: Result
The operation result.
See Also