Click or drag to resize

TransformObjectList Class

A collection of Rhino object, grip objects, and the Rhino objects that owns the grips. Used by the TransformCommand and GetTransform classes.
Inheritance Hierarchy
SystemObject
  Rhino.CollectionsTransformObjectList

Namespace:  Rhino.Collections
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class TransformObjectList : IDisposable

The TransformObjectList type exposes the following members.

Constructors
  NameDescription
Public methodTransformObjectList
Initializes a new instance of the TransformObjectList class
Top
Properties
  NameDescription
Public propertyCount
Number of elements in this list
Public propertyDisplayFeedbackEnabled
Public propertyGripCount
Number of elements in grip list
Public propertyGripOwnerCount
Number of elements in grip owner list
Top
Methods
  NameDescription
Public methodAdd(ObjRef)
Add an ObjRef to this list. Use this to add polyedges so the references are properly counted
Public methodAdd(RhinoObject)
Add a RhinoObject to this list
Public methodAddObjects
Add objects to list with a GetObject
Public methodClear
Remove all elements from this list
Public methodDispose
Releases all resources used by the TransformObjectList
Protected methodDispose(Boolean)
Releases the unmanaged resources used by the TransformObjectList and optionally releases the managed resources
Protected methodFinalize (Overrides ObjectFinalize.)
Public methodGetBoundingBox
Gets the bounding box of all of the objects that this list contains.
Public methodGripArray
Gets access to the internal GripObject array of the TransformObjectList object.
Public methodGripOwnerArray
Gets access to the internal GripOwner array of the TransformObjectList object.
Public methodObjectArray
Gets access to the internal RhinoObject array of the TransformObjectList object.
Public methodUpdateDisplayFeedbackTransform
Top
See Also