Click or drag to resize

RunMode Enumeration

Provides enumerated constants for a command running mode. This is currently interactive or scripted.

Namespace:  Rhino.Commands
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public enum RunMode
Members
  Member nameValueDescription
Interactive0 Can use dialogs for input. Must use message boxes to report serious error conditions.
Scripted1 All input must come from command line, GetPoint, GetObject, GetString, etc. Must use message boxes to report serious error conditions. Script mode gets used when a command is run with a hyphen (-) prefix.
See Also