Click or drag to resize

CommandEventArgs Class

[Missing <summary> documentation for "T:Rhino.Commands.CommandEventArgs"]

Inheritance Hierarchy
SystemObject
  SystemEventArgs
    Rhino.CommandsCommandEventArgs

Namespace:  Rhino.Commands
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class CommandEventArgs : EventArgs

The CommandEventArgs type exposes the following members.

Properties
  NameDescription
Public propertyCommandEnglishName
Gets the English name of the command that raised this event.
Public propertyCommandHelpURL
Gets the help url of the command that raised this event.
Public propertyCommandId
Gets the ID of the command that raised this event.
Public propertyCommandLocalName
Gets the name of the command that raised this event in the local language.
Public propertyCommandPluginName
Gets the name of the plug-in that this command belongs to. If the command is internal to Rhino, then this property is an empty string.
Public propertyCommandResult
Gets the result of the command that raised this event. This value is only meaningful during EndCommand events.
Public propertyDocument
Public propertyDocumentRuntimeSerialNumber
Top
Methods
  NameDescription
Top
See Also