Click or drag to resize

RenderPlugInRenderOptionsDialogPage Method

Override this method to replace the render properties page in the Rhino document properties dialog. The default implementation returns null which means just use the default Rhino page.

Namespace:  Rhino.PlugIns
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
protected virtual OptionsDialogPage RenderOptionsDialogPage(
	RhinoDoc doc
)

Parameters

doc
Type: RhinoRhinoDoc
The document properties to edit.

Return Value

Type: OptionsDialogPage
Return null to use the default Rhino page or return a page derived from OptionsDialogPage to replace the default page.
See Also