Click or drag to resize

MeshTopologyEdgeList Class

Represents an entry point to the list of edges in a mesh topology.
Inheritance Hierarchy
SystemObject
  Rhino.Geometry.CollectionsMeshTopologyEdgeList

Namespace:  Rhino.Geometry.Collections
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class MeshTopologyEdgeList

The MeshTopologyEdgeList type exposes the following members.

Properties
  NameDescription
Public propertyCount
Gets the amount of edges in this list.
Top
Methods
  NameDescription
Public methodCollapseEdge
Replaces a mesh edge with a vertex at its center and update adjacent faces as needed.
Public methodEdgeLine
Gets the 3d line along an edge.
Public methodGetConnectedFaces(Int32)
Gets indices of faces connected to an edge.
Public methodGetConnectedFaces(Int32, Boolean)
Gets indices of faces connected to an edge.
Public methodGetEdgeIndex
Returns index of edge that connects topological vertices. returns -1 if no edge is found.
Public methodGetEdgesForFace(Int32)
Gets indices of edges that surround a given face.
Public methodGetEdgesForFace(Int32, Boolean)
Gets indices of edges that surround a given face.
Public methodGetTopologyVertices
Gets the two topology vertices for a given topology edge.
Public methodIsEdgeUnwelded
Determines if the mesh edge is unwelded, or if the mesh faces that share the edge have unique vertex indices.
Public methodIsHidden
Returns true if the topological edge is hidden. The mesh topology edge is hidden only if either of its mesh topology vertices is hidden.
Public methodIsNgonInterior
Returns true if the topological edge is an interior ngon edge
Public methodIsSwappableEdge
Determines if a mesh edge index is valid input for SwapEdge(Int32).
Public methodSplitEdge(Int32, Point3d)
Divides a mesh edge to create two or more triangles
Public methodSplitEdge(Int32, Double)
Divides a mesh edge to create two or more triangles
Public methodSwapEdge
If the edge is shared by two triangular face, then the edge is swapped.
Top
See Also