Click or drag to resize

MeshTopologyEdgeListGetEdgesForFace Method (Int32, Boolean)

Gets indices of edges that surround a given face.

Namespace:  Rhino.Geometry.Collections
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public int[] GetEdgesForFace(
	int faceIndex,
	out bool[] sameOrientation
)

Parameters

faceIndex
Type: SystemInt32
A face index.
sameOrientation
Type: SystemBoolean
Same length as returned edge index array. For each edge, the sameOrientation value tells you if the edge orientation matches the face orientation (true), or is reversed (false) compared to it.

Return Value

Type: Int32
A new array of indices to the topological edges that are connected with the specified face.
See Also