MeshTopologyEdgeListCollapseEdge Method |
Replaces a mesh edge with a vertex at its center and update adjacent faces as needed.
Namespace:
Rhino.Geometry.Collections
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax public bool CollapseEdge(
int topologyEdgeIndex
)
Public Function CollapseEdge (
topologyEdgeIndex As Integer
) As Boolean
Parameters
- topologyEdgeIndex
- Type: SystemInt32
An index of a topology edge in TopologyEdges.
Return Value
Type:
Booleantrue if successful.
See Also