Click or drag to resize

Point2d Operators

The Point2d type exposes the following members.

Operators
  NameDescription
Public operatorStatic memberAddition(Point2d, Point2d)
Adds a point with a point.
Public operatorStatic memberAddition(Point2d, Vector2d)
Adds a point with a vector.
Public operatorStatic memberAddition(Vector2d, Point2d)
Adds a vector with a point.
Public operatorStatic memberDivision
Divides a Point2d by a number.
Public operatorStatic memberEquality
Determines whether two Point2d have equal values.
Public operatorStatic memberGreaterThan
Determines whether the first specified Point2d comes after (has superior sorting value than) the second point.

Coordinates evaluation priority is first X, then Y.

Public operatorStatic memberGreaterThanOrEqual
Determines whether the first specified Point2d comes after (has superior sorting value than) the second point, or it is equal to it.

Coordinates evaluation priority is first X, then Y.

Public operatorStatic memberInequality
Determines whether two Point2d have different values.
Public operatorStatic memberLessThan
Determines whether the first specified point comes before (has inferior sorting value than) the second point.

Coordinates evaluation priority is first X, then Y.

Public operatorStatic memberLessThanOrEqual
Determines whether the first specified point comes before (has inferior sorting value than) the second point, or it is equal to it.

Coordinates evaluation priority is first X, then Y.

Public operatorStatic memberMultiply(Double, Point2d)
Multiplies a Point2d by a number.
Public operatorStatic memberMultiply(Point2d, Double)
Multiplies a Point2d by a number.
Public operatorStatic memberSubtraction(Point2d, Point2d)
Subtracts point2 from point1.
Public operatorStatic memberSubtraction(Point2d, Vector2d)
Subtracts a vector from a point.
Top
See Also