RenderMaterial Methods |
The RenderMaterial type exposes the following members.
Name | Description | |
---|---|---|
AssignTo(ObjRef) | ||
AssignTo(IEnumerableObjRef, RenderMaterialAssignToSubFaceChoices, RenderMaterialAssignToBlockChoices, Boolean) | ||
BeginChange |
Begins a change or batch of changes. It may also make a
copy of the content state allowing EndChange to send an
event with the old and new contents. Calls to this method are counted;
you must call EndChange() once for every call to BeginChange().
Note:
If Changed() was called between the calls to BeginChange() and
EndChange(), the last call to EndChange() may cause the ContentChanged
BeginCreateDynamicFields |
Automatic Dynamic Field support.
Dynamic fields are typically created in the constructor of RenderContent and they are therefore created
automatically whenever the content is created. However, some advanced users require the fields to be created in response
to some user action which occurs much later. This creates the problem that the fields do not exist
by default and therefore cannot be loaded when the document is loaded. These methods are provided to solve that
problem by making it possible to automatically create the dynamic fields on loading if they don't already exist.
Dynamic fields that have this auto-create-on-load behavior are referred to as automatic dynamic fields.
Dynamic fields that do not require the advanced automatic feature can still be created by using
these methods (recommended), or they can be created manually (legacy usage).
You must call this before creating any dynamic fields. Calls to this method are counted; you must call
CalculateRenderHash | Obsolete.
Override this method to calculate the render hash of the state that
affects how the content is rendered. Does not include children or
perform any caching. Render hash values are now automatically cached by
the content framework and you do not have to worry about caching. You
also do not have to worry about iterating into children. This method
is now only called internally by the framework, use the RenderHash
ChildSlotNameFromParamName |
A "child slot" is the specific "slot" that a child (usually a texture) occupies.
This is generally the "use" of the child - in other words, the thing the child
ConvertToPhysicallyBased |
Returns a material that is the best approximation of the original, but as a physically based material.
CreateBasicMaterial(Material) | Obsolete.
Constructs a new basic material from a Material.
| |
CreateImportedMaterial | ||
Dispose(Boolean) |
Edit |
This method allows a render content hierarchy to be edited using a modal (AKA 'pop-up') editor.
If the original render content is in a document, it will remain there, and the edited one will be
'free-floating'. Therefore it is the caller's responsibility to do any replacement in the document
EndChange |
Ends a change or batch of changes. Calls to this method are counted;
you must call this method once for every call to BeginChange(RenderContentChangeContexts).
Note:
If BeginChange(RenderContentChangeContexts) was called with ChangeContexts.UI,
ChangeContexts.Program, ChangeContexts.Drop or ChangeContexts.UI.Tree
and Changed() was called between the calls to BeginChange(RenderContentChangeContexts) and
EndCreateDynamicFields |
You must call this after creating dynamic fields. Calls to this method are counted; you must call
Finalize |
ForDisplay |
**** This method is for proxies and will be marked obsolete in the future ****
The only place a single proxy can be displayed is in the
New Content Control main thumbnail. All other attempts to
use a single proxy in a UI require it to be replaced with
the corresponding multi proxy. Single proxies override this
FromMaterial |
Constructs a new material from a Material.
| |
GetChildSlotParameter |
Extra requirements are a way of specifying extra functionality on parameters in the automatic UI.
Override this function to specify additional functionality for automatic UI sections or the texture summary.
See IAutoUIExtraRequirements.h in the C++ RDK SDK for string definitions for the parameter names.
Call the base class from your override if you do not support the extra requirement parameter.
Please do not call this function. It is only retained for backward compatibility. You should instead
GetExtraRequirementParameter |
Extra requirements are a way of specifying extra functionality on parameters in the automatic UI.
GetParameter |
Query the content instance for the value of a given named parameter.
GetTextureAmountFromUsage | ||
GetTextureFromUsage | ||
GetTextureOnFromUsage | ||
HandleTexturedValueT |
Handle a textured content field. Values will be read into an
instance of TexturedColor
| |
ImportMaterialAndAssignToLayers | Imports a material file (.RMTL) and assigns the imported material to one or more layers. | |
IsFactoryProductAcceptableAsChild(Guid, String, String) |
Override this method to restrict the type of acceptable child content.
MakeCopy |
Create a copy of the render content. All content is the same, except for the
MakeGroupInstance |
Create an 'instance' of the content hierarchy and group the new hierarchy with this hierarchy.
If the instance is subsequently attached to the same document, the state of all members
of the group will be kept synchronized. With the exception of the instance ids, all
state is exactly preserved in the new instance hierarchy.
ModifyRenderContentStyles |
OnGetDefaultsInteractive |
Override this method to prompt user for information necessary to
create a new content object. For example, if you are created a
textured material you may prompt the user for a bitmap file name
OpenInEditor |
Call this method to open the content in the relevant thumbnail editor
and select it for editing by the user. The content must be in the
ParamNameFromChildSlotName |
A "child slot" is the specific "slot" that a child (usually a texture) occupies.
This is generally the "use" of the child - in other words, the thing the child
RenderHashExclude(CrcRenderHashFlags, String, LinearWorkflow) |
As RenderHash, but allows you to specify flags and exclude specific parameters.
Use this version of the function to calculate a render hash when you have the linear workflow
information and you are not running on the main thread. Access to LinearWorkflow data requires
SetChild(RenderContent, String) |
Set another content as a child of this content. This content may or may
not be attached to a document. If this content already has a child
with the specified child slot name, that child will be deleted. If
this content is not attached to a document, the child will be added
without sending any events. If this content is attached to a document,
the necessary events will be sent to update the UI.
Note:
Do not call this method to add children in your constructor. If you want to
SetChild(RenderContent, String, RenderContentChangeContexts) | Obsolete.
Set another content as a child of this content. This content may or may
not be attached to a document. If this content already has a child
with the specified child slot name, that child will be deleted. If
this content is not attached to a document, the child will be added
without sending any events. If this content is attached to a document,
the necessary events will be sent to update the UI.
Note:
Do not call this method to add children in your constructor. If you
want to add default children, you should override Initialize() and add
SetChildSlotParameter |
Extra requirements are a way of specifying extra functionality on parameters in the automatic UI.
Override this function to support values being set from automatic UI sections or the texture summary.
See IAutoUIExtraRequirements.h in the C++ RDK SDK for string definitions for the parameter names.
Call the base class from your override if you do not support the extra requirement parameter.
Please do not call this function. It is only retained for backward compatibility. You should instead
SetExtraRequirementParameter |
Extra requirements are a way of specifying extra functionality on parameters in the automatic UI.
SetIsRenderHashRecursive |
By default, RenderHash recurses into children when computing the render hash.
However, some applications may require children to be excluded from the render hash calculation.
SetParameter(String, Object) |
Set the named parameter value for this content instance.
SimulatedMaterial | Obsolete. | |
SimulateMaterial(Boolean) | Obsolete.
Call this function to receive the simulation for a RenderMaterial used by the display and other rendering engines.
| |
SimulateMaterial(Material, RenderTextureTextureGeneration) |
Override this function to provide a Rhino.DocObjects.Material definition for this material
to be used by other rendering engines including the display.
| |
SimulateMaterial(Material, Boolean) | Obsolete.
Override this function to provide a Rhino.DocObjects.Material definition for this material
to be used by other rendering engines including the display.
| |
SlotFromTextureType | ||
SmartUngroupRecursive |
Remove this content and all its children from any instance groups they may be a member of.
If any content in the same document is left alone in the group, that content is also ungrouped.
Records undo and sends events OnContentChanged and OnContentGroupIdChanged.
\note This method is designed to be called from a content UI and is intended for RDK internal
TextureChildSlotName |
Override this function to provide information about which texture is used for
the standard (ie - defined in ON_Texture) texture channels.
| |
TextureTypeFromSlot | ||
ToMaterial | ||
Ungroup |
Remove this content from any instance group it may be a member of.
UngroupRecursive |
Remove this content and all its children from any instance groups they may be a member of.
VirtualIcon |
Icon to display in the content browser, this bitmap needs to be valid for
the life of this content object, the content object that returns the bitmap