Click or drag to resize

Vector3f Methods

The Vector3f type exposes the following members.

Methods
  NameDescription
Public methodStatic memberAdd(Point3f, Vector3f)
Sums up a point and a vector, and returns a new point.

(Provided for languages that do not support operator overloading. You can use the + operator otherwise)

Public methodStatic memberAdd(Vector3f, Vector3f)
Sums up two vectors.

(Provided for languages that do not support operator overloading. You can use the + operator otherwise)

Public methodCompareTo
Compares this Vector3f with another Vector3f.

Component evaluation priority is first X, then Y, then Z.

Public methodStatic memberCrossProduct
Computes the cross product (or vector product, or exterior product) of two vectors.

This operation is not commutative.

Public methodStatic memberDivide(Vector3f, Double)
Divides a Vector3f by a number, having the effect of shrinking it, t times.

(Provided for languages that do not support operator overloading. You can use the / operator otherwise)

Public methodStatic memberDivide(Vector3f, Single)
Divides a Vector3f by a number, having the effect of shrinking it, t times.

(Provided for languages that do not support operator overloading. You can use the / operator otherwise)

Public methodEpsilonEquals
Check that all values in other are within epsilon of the values in this
Public methodEquals(Object)
Determines whether the specified System.Object is a Vector3f and has the same values as the present vector.
(Overrides ValueTypeEquals(Object).)
Public methodEquals(Vector3f)
Determines whether the specified vector has the same values as the present vector.
Public methodGetHashCode
Computes a hash number that represents the current vector.
(Overrides ValueTypeGetHashCode.)
Public methodStatic memberMultiply(Single, Vector3f)
Multiplies a vector by a number, having the effect of scaling it.

(Provided for languages that do not support operator overloading. You can use the * operator otherwise)

Public methodStatic memberMultiply(Vector3f, Vector3f)
Multiplies two Vector3f together, returning the dot (internal) product of the two. This is not the cross product.

(Provided for languages that do not support operator overloading. You can use the * operator otherwise)

Public methodStatic memberMultiply(Vector3f, Single)
Multiplies a vector by a number, having the effect of scaling it.

(Provided for languages that do not support operator overloading. You can use the * operator otherwise)

Public methodStatic memberNegate
Computes the reversed vector.

(Provided for languages that do not support operator overloading. You can use the - unary operator otherwise)

Public methodPerpendicularTo
Sets this vector to be perpendicular to another vector. Result is not unitized.
Public methodReverse
Reverses this vector in place (reverses the direction).

If this vector contains RhinoMath.UnsetValue, the reverse will also be invalid and false will be returned.

Public methodRotate
Rotates this vector around a given axis.
Public methodStatic memberSubtract
Subtracts the second vector from the first one.

(Provided for languages that do not support operator overloading. You can use the - operator otherwise)

Public methodToString
Constructs the string representation of the current vector.
(Overrides ValueTypeToString.)
Public methodToString(String, IFormatProvider)
Formats the value of the current instance using the specified format.
Public methodTransform
Transforms the vector in place.

The transformation matrix acts on the left of the vector; i.e.,

result = transformation*vector

Public methodUnitize
Unitizes the vector in place. A unit vector has length 1 unit.

An invalid or zero length vector cannot be unitized.

Top
See Also