Compares this
Vector3f with another
Vector3f.
Component evaluation priority is first X, then Y, then Z.
Namespace:
Rhino.Geometry
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax public int CompareTo(
Vector3f other
)
Public Function CompareTo (
other As Vector3f
) As Integer
Parameters
- other
- Type: Rhino.GeometryVector3f
The other Vector3f to use in comparison.
Return Value
Type:
Int32 0: if this is identical to other
-1: if this.X < other.X
-1: if this.X == other.X and this.Y < other.Y
-1: if this.X == other.X and this.Y == other.Y and this.Z < other.Z
+1: otherwise.
Implements
IComparableTCompareTo(T)See Also