Rotates this vector around a given axis.
Namespace:
Rhino.Geometry
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax public bool Rotate(
double angleRadians,
Vector3f rotationAxis
)
Public Function Rotate (
angleRadians As Double,
rotationAxis As Vector3f
) As Boolean
Parameters
- angleRadians
- Type: SystemDouble
Angle of rotation (in radians). - rotationAxis
- Type: Rhino.GeometryVector3f
Axis of rotation.
Return Value
Type:
Booleantrue on success, false on failure.
See Also