Click or drag to resize

Vector2d Methods

The Vector2d type exposes the following members.

Methods
  NameDescription
Public methodStatic memberAdd
Sums up two vectors.

(Provided for languages that do not support operator overloading. You can use the + operator otherwise)

Public methodCompareTo
Compares this Vector2d with another Vector2d.

Components evaluation priority is first X, then Y.

Public methodStatic memberDivide
Divides a Vector2d by a number, having the effect of shrinking it.

(Provided for languages that do not support operator overloading. You can use the / operator otherwise)

Public methodEpsilonEquals
Check that all values in other are within epsilon of the values in this
Public methodEquals(Object)
Determines whether the specified System.Object is a Vector2d and has the same value as the present vector.
(Overrides ValueTypeEquals(Object).)
Public methodEquals(Vector2d)
Determines whether the specified vector has the same value as the present vector.
Public methodGetHashCode
Provides a hashing value for the present vector.
(Overrides ValueTypeGetHashCode.)
Public methodIsTiny
Uses RhinoMath.ZeroTolerance for IsTiny calculation.
Public methodCode exampleIsTiny(Double)
Determines whether a vector is very short.
Public methodStatic memberMultiply(Double, Vector2d)
Multiplies a vector by a number, having the effect of scaling it.

(Provided for languages that do not support operator overloading. You can use the * operator otherwise)

Public methodStatic memberMultiply(Vector2d, Vector2d)
Multiplies two vectors together, returning the dot product (or inner product).

(Provided for languages that do not support operator overloading. You can use the * operator otherwise)

Public methodStatic memberMultiply(Vector2d, Double)
Multiplies a vector by a number, having the effect of scaling it.

(Provided for languages that do not support operator overloading. You can use the * operator otherwise)

Public methodStatic memberNegate
Computes the reversed vector.

(Provided for languages that do not support operator overloading. You can use the - unary operator otherwise)

Public methodRotate
Rotates this vector.
Public methodStatic memberSubtract
Subtracts the second vector from the first one.

(Provided for languages that do not support operator overloading. You can use the - operator otherwise)

Public methodToString
Constructs a string representation of the current vector.
(Overrides ValueTypeToString.)
Public methodToString(String, IFormatProvider)
Formats the value of the current instance using the specified format.
Public methodUnitize
Unitizes the vector in place. A unit vector has length 1 unit.

An invalid or zero length vector cannot be unitized.

Top
See Also