Click or drag to resize

Vector2dNegate Method

Computes the reversed vector.

(Provided for languages that do not support operator overloading. You can use the - unary operator otherwise)

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 6.0
Syntax
public static Vector2d Negate(
	Vector2d vector
)

Parameters

vector
Type: Rhino.GeometryVector2d
A vector to negate.

Return Value

Type: Vector2d
A new vector where all components were multiplied by -1.
See Also