Click or drag to resize

Point2d Methods

The Point2d type exposes the following members.

Methods
  NameDescription
Public methodStatic memberAdd(Point2d, Point2d)
Adds a point with a point.

(Provided for languages that do not support operator overloading. You can use the + operator otherwise)

Public methodStatic memberAdd(Point2d, Vector2d)
Adds a point with a vector.

(Provided for languages that do not support operator overloading. You can use the + operator otherwise)

Public methodStatic memberAdd(Vector2d, Point2d)
Adds a vector with a point.

(Provided for languages that do not support operator overloading. You can use the + operator otherwise)

Public methodCompareTo
Compares this Point2d with another Point2d.

Coordinates evaluation priority is first X, then Y.

Public methodCode exampleDistanceTo
Computes the distance between two points.
Public methodDistanceToSquared
Computes the square of the distance between two 2d points.

This method is usually largely faster than DistanceTo().

Public methodStatic memberDivide
Divides a Point2d by a number.

(Provided for languages that do not support operator overloading. You can use the / operator otherwise)

Public methodEpsilonEquals
Check that all values in other are within epsilon of the values in this
Public methodEquals(Object)
Determines whether the specified System.Object is a Point2d and has the same values as the present point.
(Overrides ValueTypeEquals(Object).)
Public methodEquals(Point2d)
Determines whether the specified Point2d has the same values as the present point.
Public methodGetHashCode
Computes a hash number that represents the current point.
(Overrides ValueTypeGetHashCode.)
Public methodStatic memberMultiply(Double, Point2d)
Multiplies a Point2d by a number.

(Provided for languages that do not support operator overloading. You can use the * operator otherwise)

Public methodStatic memberMultiply(Point2d, Double)
Multiplies a Point2d by a number.

(Provided for languages that do not support operator overloading. You can use the * operator otherwise)

Public methodStatic memberSubtract(Point2d, Point2d)
Subtracts the second point from the first point.

(Provided for languages that do not support operator overloading. You can use the - operator otherwise)

Public methodStatic memberSubtract(Point2d, Vector2d)
Subtracts a vector from a point.

(Provided for languages that do not support operator overloading. You can use the - operator otherwise)

Public methodToString
Constructs the string representation for the current point.
(Overrides ValueTypeToString.)
Public methodToString(String, IFormatProvider)
Formats the value of the current instance using the specified format.
Public methodTransform
Transforms the present point in place. The transformation matrix acts on the left of the point. i.e.,

result = transformation*point

Top
See Also