Click or drag to resize

Point2dCompareTo Method

Compares this Point2d with another Point2d.

Coordinates evaluation priority is first X, then Y.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public int CompareTo(
	Point2d other
)

Parameters

other
Type: Rhino.GeometryPoint2d
The other Point2d to use in comparison.

Return Value

Type: Int32

0: if this is identical to other

-1: if this.X < other.X

-1: if this.X == other.X and this.Y < other.Y

+1: otherwise.

Implements

IComparableTCompareTo(T)
See Also