Centermark Methods |
The Centermark type exposes the following members.
Name | Description | |
---|---|---|
AdjustFromPoints |
Update dimension geometry from point locations.
ComponentIndex |
If this piece of geometry is a component in something larger, like a BrepEdge
Create(DimensionStyle, Plane, Curve, Double) | Creates a new center mark dimension. | |
DuplicateShallow |
Constructs a light copy of this object. By "light", it is meant that the same
underlying data is used until something is done to attempt to change it. For example,
you could have a shallow copy of a very heavy mesh object and the same underlying
data will be used when doing things like inspecting the number of faces on the mesh.
If you modify the location of one of the mesh vertices, the shallow copy will create
a full duplicate of the underlying mesh data and the shallow copy will become a
EnsurePrivateCopy |
If you want to keep a copy of this class around by holding onto it in a variable after a command
completes, call EnsurePrivateCopy to make sure that this class is not tied to the document. You can
GetDimensionStyle |
Return the proper dimension style from which to get properties
for this annotation object
If this object has style overrides, those will be included in the
returned dimension style and the style will be updated to include
IsValidWithLog |
Determines if an object is valid. Also provides a report on errors if this
MakeDeformable |
If possible, converts the object into a form that can be accurately modified
Rotate |
Rotates the object about the specified axis. A positive rotation
SetOverrideDimStyle |
Set a style including overrides for this annotation object.
The DimensionStyle OverrideStyle must have the override fields marked
as overridden and must have it's Id set to nil.
Use DimensinoStyle.SetFieldOverride(Field field) and related functions
to manage override settings. To override a field, the field value must be set
and the field must be marked as an override.
Transform |
Transforms the geometry. If the input Transform has a SimilarityType of
OrientationReversing, you may want to consider flipping the transformed
geometry after calling this function when it makes sense. For example,