Click or drag to resize

Arc Methods

The Arc type exposes the following members.

Methods
  NameDescription
Public methodBoundingBox
Computes the 3D axis aligned bounding box for this arc.
Public methodClosestParameter
Gets parameter on the arc closest to a test point.
Public methodClosestPoint
Computes the point on an arc that is closest to a test point.
Public methodEpsilonEquals
Check that all values in other are within epsilon of the values in this
Public methodEquals(Arc)
Determines whether another arc has the same value as this arc.
Public methodEquals(Object)
Determines whether another object is an arc and has the same value as this arc.
(Overrides ValueTypeEquals(Object).)
Public methodGetHashCode
Computes a hash code for the present arc.
(Overrides ValueTypeGetHashCode.)
Public methodPointAt
Gets the point at the given arc parameter.
Public methodReverse
Reverses the orientation of the arc. Changes the domain from [a,b] to [-b,-a].
Public methodTangentAt
Gets the tangent at the given parameter.
Public methodToNurbsCurve
Initializes a nurbs curve representation of this arc. This amounts to the same as calling NurbsCurve.CreateFromArc().
Public methodToNurbsCurve(Int32, Int32)
Create a uniform non-rational cubic NURBS approximation of an arc.
Public methodTransform
Transforms the arc using a Transformation matrix.
Public methodTrim
Sets arc's angle domain (in Radians) as a sub-domain of the circle.
Top
See Also