Click or drag to resize

ArcClosestParameter Method

Gets parameter on the arc closest to a test point.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public double ClosestParameter(
	Point3d testPoint
)

Parameters

testPoint
Type: Rhino.GeometryPoint3d
Point to get close to.

Return Value

Type: Double
Parameter (in radians) of the point on the arc that is closest to the test point. If testPoint is the center of the arc, then the starting point of the arc is (arc.Domain()[0]) returned. If no parameter could be found, RhinoMath.UnsetValue is returned.
See Also