Click or drag to resize

TransformTextureMapping Method

Construct a UVW Transform from components.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 8.0
Syntax
public static Transform TextureMapping(
	Vector3d offset,
	Vector3d repeat,
	Vector3d rotation
)

Parameters

offset
Type: Rhino.GeometryVector3d

[Missing <param name="offset"/> documentation for "M:Rhino.Geometry.Transform.TextureMapping(Rhino.Geometry.Vector3d,Rhino.Geometry.Vector3d,Rhino.Geometry.Vector3d)"]

repeat
Type: Rhino.GeometryVector3d

[Missing <param name="repeat"/> documentation for "M:Rhino.Geometry.Transform.TextureMapping(Rhino.Geometry.Vector3d,Rhino.Geometry.Vector3d,Rhino.Geometry.Vector3d)"]

rotation
Type: Rhino.GeometryVector3d

[Missing <param name="rotation"/> documentation for "M:Rhino.Geometry.Transform.TextureMapping(Rhino.Geometry.Vector3d,Rhino.Geometry.Vector3d,Rhino.Geometry.Vector3d)"]

Return Value

Type: Transform

[Missing <returns> documentation for "M:Rhino.Geometry.Transform.TextureMapping(Rhino.Geometry.Vector3d,Rhino.Geometry.Vector3d,Rhino.Geometry.Vector3d)"]

See Also