RhinoCommon API
RhinoCommon API
Namespaces
Rhino.Geometry
Transform Structure
Transform Methods
Affineize Method
ChangeBasis Method
Clone Method
CompareTo Method
DecomposeAffine Method
DecomposeRigid Method
DecomposeSimilarity Method
DecomposeSymmetric Method
DecomposeTextureMapping Method
Diagonal Method
Equals Method
GetEulerZYZ Method
GetHashCode Method
GetQuaternion Method
GetYawPitchRoll Method
IsRigid Method
IsSimilarity Method
IsZeroTransformationWithTolerance Method
Linearize Method
Mirror Method
Multiply Method
Orthogonalize Method
PlanarProjection Method
PlaneToPlane Method
ProjectAlong Method
Rotation Method
RotationZYX Method
RotationZYZ Method
Scale Method
Shear Method
TextureMapping Method
ToDoubleArray Method
ToFloatArray Method
ToString Method
TransformBoundingBox Method
TransformList Method
Translation Method
Transpose Method
TryGetInverse Method
Transform
Affineize Method
Replaces the last row with (0 0 0 1), discarding any perspective part of this transform
Namespace:
Rhino.Geometry
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since:
6.12
Syntax
C#
VB
Copy
public
void
Affineize
()
Public
Sub
Affineize
See Also
Reference
Transform Structure
Rhino.Geometry Namespace
Rhino 8.13.24317.13000 (2024-11-12)
Copyright © 2009-2024 Robert McNeel & Associates
Report wishes and bugs at discourse.mcneel.com