Click or drag to resize

BezierSurfaceGetControlVertex4d Method

Get location of a control vertex.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 7.1
Syntax
public Point4d GetControlVertex4d(
	int i,
	int j
)

Parameters

i
Type: SystemInt32
Control vertex index (0 <= index < ControlVertexCount)
j
Type: SystemInt32
Control vertex index (0 <= index < ControlVertexCount)

Return Value

Type: Point4d
Homogeneous value of control vertex. If the bezier is not rational, the weight is 1.
Exceptions
ExceptionCondition
ArgumentOutOfRangeExceptionwhen index is out of range
See Also