Click or drag to resize

BezierSurface Methods

The BezierSurface type exposes the following members.

Methods
  NameDescription
Public methodControlVertexCount
Number of control vertices in this surface
Public methodStatic memberCreateLoftedBezier
Loft a bezier surface through a list of bezier curves.
Public methodDispose
Actively reclaims unmanaged resources that this instance uses.
Protected methodDispose(Boolean)
For derived class implementers.

This method is called with argument true when class user calls Dispose(), while with argument false when the Garbage Collector invokes the finalizer, or Finalize() method.

You must reclaim all used unmanaged resources in both cases, and can use this chance to call Dispose on disposable fields if the argument is true.

Also, you must call the base virtual method within your overriding method.

Public methodDomain
Gets the domain in a direction.
Protected methodFinalize
Passively reclaims unmanaged resources when the class user did not explicitly call Dispose().
(Overrides ObjectFinalize.)
Public methodGetBoundingBox
Bounding box solver. Gets the world axis aligned bounding box for the surface.
Public methodGetControlVertex2d
Get location of a control vertex.
Public methodGetControlVertex3d
Get location of a control vertex.
Public methodGetControlVertex4d
Get location of a control vertex.
Public methodMakeNonRational
Make bezier non-rational
Public methodMakeRational
Make bezier rational
Public methodPointAt
Evaluates point at a surface parameter.
Public methodReverse
Reverses parameterization Domain changes from [a,b] to [-b,-a]
Public methodSplit
Divides the Bezier surface at the specified parameter.
Public methodToNurbsSurface
Constructs a NURBS surface representation of this surface.
Public methodTransform
Transforms the surface
Public methodTranspose
Transposes surface parameterization (swap U and V)
Top
See Also