Click or drag to resize

BezierSurfaceGetControlVertex2d Method

Get location of a control vertex.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 7.1
Syntax
public Point2d GetControlVertex2d(
	int i,
	int j
)

Parameters

i
Type: SystemInt32
Control vertex index (0 <= index < ControlVertexCount)
j
Type: SystemInt32
Control vertex index (0 <= index < ControlVertexCount)

Return Value

Type: Point2d
If the bezier is rational, the euclidean location is returned.
Exceptions
ExceptionCondition
ArgumentOutOfRangeExceptionwhen i or j is out of range
See Also