MeshTopologyVertexList Class |
Namespace: Rhino.Geometry.Collections
The MeshTopologyVertexList type exposes the following members.
Name | Description | |
---|---|---|
Count |
Gets or sets the number of mesh topology vertices.
| |
Item |
Gets or sets the vertex at the given index. Setting a location adjusts all vertices
in the mesh's vertex list that are defined by this topological vertex
The index must be valid or an IndexOutOfRangeException will be thrown.
|
Name | Description | |
---|---|---|
ConnectedEdge |
Gets a particular edge that is connected to a topological vertex.
Call TopologyVertices.SortVertices before this if you are interested in ordered edges. | |
ConnectedEdges |
Gets all edges that are connected to a given vertex.
Call TopologyVertices.SortVertices before this if you are interested in ordered edges. | |
ConnectedEdgesCount |
Gets the count of edges that are connected to a given vertex.
| |
ConnectedFaces |
Gets all faces that are connected to a given vertex.
| |
ConnectedTopologyVertices(Int32) |
Gets all topological vertices that are connected to a given vertex.
| |
ConnectedTopologyVertices(Int32, Boolean) |
Gets all topological vertices that are connected to a given vertex.
| |
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.) | |
Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.) | |
GetEnumerator |
Gets an enumerator that yields all topology vertices in this collection.
| |
GetHashCode | Serves as the default hash function. (Inherited from Object.) | |
GetType | Gets the Type of the current instance. (Inherited from Object.) | |
IndicesFromFace |
Returns TopologyVertexIndices for a given mesh face index.
| |
IsHidden |
Returns true if the topological vertex is hidden. The mesh topology
vertex is hidden if and only if all the ON_Mesh vertices it represents is hidden.
| |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.) | |
MeshVertexIndices |
Gets all indices of the mesh vertices that a given topology vertex represents.
| |
SortEdges |
Sorts the edge list for the mesh topology vertex list so that
the edges are in radial order when you call ConnectedTopologyVertices.
A non-manifold edge is treated as a boundary edge with respect
to sorting. If any boundary or non-manifold edges end at the
vertex, then the first edge will be a boundary or non-manifold edge.
| |
SortEdges(Int32) |
Sorts the edge list for as single mesh topology vertex so that
the edges are in radial order when you call ConnectedTopologyVertices.
A non-manifold edge is treated as a boundary edge with respect
to sorting. If any boundary or non-manifold edges end at the
vertex, then the first edge will be a boundary or non-manifold edge.
| |
TopologyVertexIndex |
Gets the topology vertex index for an existing mesh vertex in the mesh's
VertexList.
| |
ToString | Returns a string that represents the current object. (Inherited from Object.) |