InstanceDefinitionTable Class |
[Missing <summary> documentation for "T:Rhino.DocObjects.Tables.InstanceDefinitionTable"]
Namespace: Rhino.DocObjects.Tables
The InstanceDefinitionTable type exposes the following members.
Name | Description | |
---|---|---|
ActiveCount |
Number of items in the instance definitions table, excluding deleted definitions.
| |
ComponentType | (Overrides CommonComponentTableTComponentType.) | |
Count | Number of items in the instance definitions table. (Overrides CommonComponentTableTCount.) | |
Document | Document that owns this table. | |
Item |
Conceptually, the InstanceDefinition table is an array of Instance
definitions. The operator[] can be used to get individual instance
definition. An instance definition is either active or deleted and this
state is reported by IsDeleted or will be null if it has been purged
from the document.
|
Name | Description | |
---|---|---|
Add(String, String, Point3d, IEnumerableGeometryBase) |
Adds an instance definition to the instance definition table.
| |
Add(String, String, Point3d, GeometryBase, ObjectAttributes) |
Adds an instance definition to the instance definition table.
| |
Add(String, String, Point3d, IEnumerableGeometryBase, IEnumerableObjectAttributes) |
Adds an instance definition to the instance definition table.
| |
Add(String, String, String, String, Point3d, IEnumerableGeometryBase, IEnumerableObjectAttributes) |
Adds an instance definition to the instance definition table.
| |
Clear |
Marks all items as deleted.
(Inherited from CommonComponentTableT.) | |
Compact |
Purge deleted instance definition information that is not in use.
This function is time consuming and should be used in a thoughtful manner.
| |
Delete(InstanceDefinition) |
Deletes the instance definition. This deletes all references too.
(Overrides CommonComponentTableTDelete(T).) | |
Delete(Int32, Boolean, Boolean) |
Deletes the instance definition.
| |
DestroySourceArchive |
Destroys all source archive information.
Specifically:
* SourceArchive is set to the empty string.
* SourceRelativePath is set to false
* The alternative source archive path is set to the empty string.
* Checksum.Zero() is used to private destroy all checksum information.
* UpdateType is set to Static.
| |
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.) | |
Find(String) | Finds the instance definition with a given name. | |
Find(Guid, Boolean) | Finds the instance definition with a given id. | |
Find(String, Boolean) | Obsolete. Finds the instance definition with a given name. | |
FindId |
Uses the guid to find a model component. Deleted objects cannot be found by id.
The guid is the value that is stored in the .Id property.
In a single document, no two active objects have the same guid. If an object is
replaced with a new object, then the guid persists. For example, if the _Move command
moves an object, then the moved object inherits its guid from the starting object.
If the Copy command copies an object, then the copy gets a new guid. This guid persists
through file saving/opening operations. This function will not find grip objects.
(Inherited from CommonComponentTableT.) | |
GetEnumerator | (Overrides CommonComponentTableTGetEnumerator.) | |
GetHashCode | Serves as the default hash function. (Inherited from Object.) | |
GetList |
Gets an array of instance definitions.
| |
GetType | Gets the Type of the current instance. (Inherited from Object.) | |
GetUnusedInstanceDefinitionName |
Gets unused instance definition name used as default when creating
new instance definitions.
| |
GetUnusedInstanceDefinitionName(String) |
Gets unused instance definition name used as default when creating
new instance definitions.
| |
GetUnusedInstanceDefinitionName(String, UInt32) | Obsolete.
Gets unused instance definition name used as default when creating
new instance definitions.
| |
InstanceDefinitionIndex |
Get the index of the instance definition with a given id.
| |
MakeSourcePathRelative | Obsolete.
Obsolete method that always returns false.
Marks the source path for a linked instance definition as relative or absolute.
| |
Modify(Int32, UserData, Boolean) |
Modifies the instance definition user data.
Does not change instance definition ID or geometry.
| |
Modify(InstanceDefinition, String, String, Boolean) |
Modifies the instance definition name and description.
Does not change instance definition ID or geometry.
| |
Modify(Int32, String, String, Boolean) |
Modifies the instance definition name and description.
Does not change instance definition ID or geometry.
| |
Modify(InstanceDefinition, String, String, String, String, Boolean) |
Modifies the instance definition name, description, and url.
Does not change instance definition ID or geometry.
| |
Modify(Int32, String, String, String, String, Boolean) |
Modifies the instance definition name, description, and url.
Does not change instance definition ID or geometry.
| |
ModifyGeometry(Int32, IEnumerableGeometryBase) | ||
ModifyGeometry(Int32, GeometryBase, ObjectAttributes) | ||
ModifyGeometry(Int32, IEnumerableGeometryBase, IEnumerableObjectAttributes) |
Modifies the instance definition geometry and replaces all references
to the current definition with references to the new definition.
| |
ModifySourceArchive |
If the instance definition is linked or embedded, use SetSource to
specify the source archive.
| |
Purge |
Purges an instance definition and its definition geometry.
| |
RefreshLinkedBlock |
Reload linked block definitions and update the Rhino display.
| |
ToString | Returns a string that represents the current object. (Inherited from Object.) | |
Undelete |
Undeletes an instance definition that has been deleted by Delete()
| |
UndoModify |
Restores the instance definition to its previous state,
if the instance definition has been modified and the modification can be undone.
| |
UpdateLinkedInstanceDefinition |
Read the objects from a file and use them as the instance's definition geometry.
|