Click or drag to resize

InstanceDefinitionTableDestroySourceArchive Method

Destroys all source archive information. Specifically: * SourceArchive is set to the empty string. * SourceRelativePath is set to false * The alternative source archive path is set to the empty string. * Checksum.Zero() is used to private destroy all checksum information. * UpdateType is set to Static.

Namespace:  Rhino.DocObjects.Tables
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 6.0
Syntax
public bool DestroySourceArchive(
	InstanceDefinition definition,
	bool quiet
)

Parameters

definition
Type: Rhino.DocObjectsInstanceDefinition
The instance definition to be modified.
quiet
Type: SystemBoolean
If true, then message boxes about erroneous parameters will not be shown.

Return Value

Type: Boolean
Returns true if the definition was successfully modified otherwise returns false.
See Also