Click or drag to resize

InstanceDefinitionTable Methods

The InstanceDefinitionTable type exposes the following members.

Methods
  NameDescription
Public methodCode exampleAdd(String, String, Point3d, IEnumerableGeometryBase)
Adds an instance definition to the instance definition table.
Public methodAdd(String, String, Point3d, GeometryBase, ObjectAttributes)
Adds an instance definition to the instance definition table.
Public methodCode exampleAdd(String, String, Point3d, IEnumerableGeometryBase, IEnumerableObjectAttributes)
Adds an instance definition to the instance definition table.
Public methodAdd(String, String, String, String, Point3d, IEnumerableGeometryBase, IEnumerableObjectAttributes)
Adds an instance definition to the instance definition table.
Public methodCompact
Purge deleted instance definition information that is not in use. This function is time consuming and should be used in a thoughtful manner.
Public methodDelete(InstanceDefinition)
Deletes the instance definition. This deletes all references too.
(Overrides CommonComponentTableTDelete(T).)
Public methodDelete(Int32, Boolean, Boolean)
Deletes the instance definition.
Public methodDestroySourceArchive
Destroys all source archive information. Specifically: * SourceArchive is set to the empty string. * SourceRelativePath is set to false * The alternative source archive path is set to the empty string. * Checksum.Zero() is used to private destroy all checksum information. * UpdateType is set to Static.
Public methodCode exampleFind(String)
Finds the instance definition with a given name.
Public methodFind(Guid, Boolean)
Finds the instance definition with a given id.
Public methodCode exampleFind(String, Boolean) Obsolete.
Finds the instance definition with a given name.
Public methodGetEnumerator (Overrides CommonComponentTableTGetEnumerator.)
Public methodGetList
Gets an array of instance definitions.
Public methodGetUnusedInstanceDefinitionName
Gets unused instance definition name used as default when creating new instance definitions.
Public methodGetUnusedInstanceDefinitionName(String)
Gets unused instance definition name used as default when creating new instance definitions.
Public methodGetUnusedInstanceDefinitionName(String, UInt32) Obsolete.
Gets unused instance definition name used as default when creating new instance definitions.
Public methodInstanceDefinitionIndex
Get the index of the instance definition with a given id.
Public methodMakeSourcePathRelative Obsolete.
Obsolete method that always returns false. Marks the source path for a linked instance definition as relative or absolute.
Public methodModify(Int32, UserData, Boolean)
Modifies the instance definition user data. Does not change instance definition ID or geometry.
Public methodModify(InstanceDefinition, String, String, Boolean)
Modifies the instance definition name and description. Does not change instance definition ID or geometry.
Public methodCode exampleModify(Int32, String, String, Boolean)
Modifies the instance definition name and description. Does not change instance definition ID or geometry.
Public methodModify(InstanceDefinition, String, String, String, String, Boolean)
Modifies the instance definition name, description, and url. Does not change instance definition ID or geometry.
Public methodModify(Int32, String, String, String, String, Boolean)
Modifies the instance definition name, description, and url. Does not change instance definition ID or geometry.
Public methodModifyGeometry(Int32, IEnumerableGeometryBase)
Public methodModifyGeometry(Int32, GeometryBase, ObjectAttributes)
Public methodModifyGeometry(Int32, IEnumerableGeometryBase, IEnumerableObjectAttributes)
Modifies the instance definition geometry and replaces all references to the current definition with references to the new definition.
Public methodModifySourceArchive
If the instance definition is linked or embedded, use SetSource to specify the source archive.
Public methodPurge
Purges an instance definition and its definition geometry.
Public methodRefreshLinkedBlock
Reload linked block definitions and update the Rhino display.
Public methodUndelete
Undeletes an instance definition that has been deleted by Delete()
Public methodUndoModify
Restores the instance definition to its previous state, if the instance definition has been modified and the modification can be undone.
Public methodUpdateLinkedInstanceDefinition
Read the objects from a file and use them as the instance's definition geometry.
Top
See Also