Click or drag to resize

InstanceDefinitionTableGetUnusedInstanceDefinitionName Method (String)

Gets unused instance definition name used as default when creating new instance definitions.

Namespace:  Rhino.DocObjects.Tables
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public string GetUnusedInstanceDefinitionName(
	string root
)

Parameters

root
Type: SystemString
The returned name is 'root nn' If root is empty, then 'Block' (localized) is used.

Return Value

Type: String
An unused instance definition name string.
See Also