Click or drag to resize

InstanceDefinitionTableModify Method (InstanceDefinition, String, String, Boolean)

Modifies the instance definition name and description. Does not change instance definition ID or geometry.

Namespace:  Rhino.DocObjects.Tables
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public bool Modify(
	InstanceDefinition idef,
	string newName,
	string newDescription,
	bool quiet
)

Parameters

idef
Type: Rhino.DocObjectsInstanceDefinition
The instance definition to be modified.
newName
Type: SystemString
The new name.
newDescription
Type: SystemString
The new description string.
quiet
Type: SystemBoolean
If false, information message boxes pop up when illegal changes are attempted.

Return Value

Type: Boolean
true if successful.
See Also