Click or drag to resize

ColorRGBA Structure

Represents a sRGBA (Red, Green, Blue, Alpha) color with double precision floating point channel.

Namespace:  Rhino.Display
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
[SerializableAttribute]
public struct ColorRGBA : ISerializable, IFormattable, 
	IComparable, IComparable<ColorRGBA>, IEquatable<ColorRGBA>, 
	IEpsilonComparable<ColorRGBA>

The ColorRGBA type exposes the following members.

Constructors
  NameDescription
Public methodColorRGBA(Color)
Constructs a new instance of ColorRGBA that is equivalent to an ARGB color.
Public methodColorRGBA(ColorRGBA)
Initializes a new instance of the ColorRGBA class
Public methodColorRGBA(Int32)
Constructs a new instance of ColorRGBA that is equivalent to an ARGB color.
Public methodColorRGBA(ColorRGBA, Double)
Initializes a new instance of the ColorRGBA class
Public methodColorRGBA(Double, Double, Double)
Initializes a new instance of the ColorRGBA class
Public methodColorRGBA(Double, Double, Double, Double)
Initializes a new instance of the ColorRGBA class
Top
Properties
  NameDescription
Public propertyA
Gets or sets the alpha channel value. Alpha channels are limited to a 0~1 range.
Public propertyB
Gets or sets the blue channel value. Blue channels are limited to a 0~1 range.
Public propertyStatic memberBlack
Public propertyStatic memberBlue
Public propertyG
Gets or sets the green channel value. Green channels are limited to a 0~1 range.
Public propertyStatic memberGreen
Public propertyR
Gets or sets the red channel value. Red channels are limited to a 0~1 range.
Public propertyStatic memberRed
Public propertyStatic memberWhite
Top
Methods
  NameDescription
Public methodStatic memberApplyGamma
Public methodBlendTo
Public methodCompareTo
Compares this ColorRGBA with another ColorRGBA.

Channels evaluation priority is first A, then R, then G, then B.

Public methodStatic memberCreateFromArgb(Byte, Byte, Byte)
Constructs a RGBA color from the specified 8-bit components (red, green, and blue) values. The alpha value is implicitly 1.0 (fully opaque).
Public methodStatic memberCreateFromArgb(Byte, Byte, Byte, Byte)
Constructs a RGBA color from the four ARGB components (alpha, red, green, and blue) values.
Public methodStatic memberCreateFromCMYK
Create the nearest RGBA equivalent of a CMYK color.
Public methodStatic memberCreateFromHSL
Constructs the nearest RGBA equivalent of an HSV color.
Public methodStatic memberCreateFromHSV
Constructs the nearest RGBA equivalent of an HSL color.
Public methodStatic memberCreateFromLAB
Create the nearest RGBA equivalent of a LAB color.
Public methodStatic memberCreateFromLCH
Create the nearest RGBA equivalent of a LCH color.
Public methodStatic memberCreateFromXYZ
Create the nearest RGBA equivalent of an XYZ color.
Public methodEpsilonEquals
Check that all values in other are within epsilon of the values in this
Public methodEquals(ColorRGBA)
Determines whether the specified ColorRGBA has the same values as the present color.
Public methodEquals(Object) (Overrides ValueTypeEquals(Object).)
Public methodGetHashCode (Overrides ValueTypeGetHashCode.)
Public methodToArgb
Converts this color to a 32-bit ARGB value.
Public methodToString (Overrides ValueTypeToString.)
Public methodToString(String, IFormatProvider)
Top
Operators
See Also