Click or drag to resize

ColorRGBA Methods

The ColorRGBA type exposes the following members.

Methods
  NameDescription
Public methodStatic memberApplyGamma
Public methodBlendTo
Public methodCompareTo
Compares this ColorRGBA with another ColorRGBA.

Channels evaluation priority is first A, then R, then G, then B.

Public methodStatic memberCreateFromArgb(Byte, Byte, Byte)
Constructs a RGBA color from the specified 8-bit components (red, green, and blue) values. The alpha value is implicitly 1.0 (fully opaque).
Public methodStatic memberCreateFromArgb(Byte, Byte, Byte, Byte)
Constructs a RGBA color from the four ARGB components (alpha, red, green, and blue) values.
Public methodStatic memberCreateFromCMYK
Create the nearest RGBA equivalent of a CMYK color.
Public methodStatic memberCreateFromHSL
Constructs the nearest RGBA equivalent of an HSV color.
Public methodStatic memberCreateFromHSV
Constructs the nearest RGBA equivalent of an HSL color.
Public methodStatic memberCreateFromLAB
Create the nearest RGBA equivalent of a LAB color.
Public methodStatic memberCreateFromLCH
Create the nearest RGBA equivalent of a LCH color.
Public methodStatic memberCreateFromXYZ
Create the nearest RGBA equivalent of an XYZ color.
Public methodEpsilonEquals
Check that all values in other are within epsilon of the values in this
Public methodEquals(ColorRGBA)
Determines whether the specified ColorRGBA has the same values as the present color.
Public methodEquals(Object) (Overrides ValueTypeEquals(Object).)
Public methodGetHashCode (Overrides ValueTypeGetHashCode.)
Public methodToArgb
Converts this color to a 32-bit ARGB value.
Public methodToString (Overrides ValueTypeToString.)
Public methodToString(String, IFormatProvider)
Top
See Also