Click or drag to resize

Vector3d Operators and Type Conversions

The Vector3d type exposes the following members.

Operators
  NameDescription
Public operatorStatic memberAddition
Sums up two vectors.
Public operatorStatic memberDivision
Divides a Vector3d by a number, having the effect of shrinking it.
Public operatorStatic memberEquality
Determines whether two vectors have the same value.
Public operatorStatic memberGreaterThan
Determines whether the first specified vector comes after (has superior sorting value than) the second vector.

Components evaluation priority is first X, then Y, then Z.

Public operatorStatic memberGreaterThanOrEqual
Determines whether the first specified vector comes after (has superior sorting value than) the second vector, or it is equal to it.

Components evaluation priority is first X, then Y, then Z.

Public operatorStatic member(Vector3f to Vector3d)
Converts a single-precision (float) vector in a double-precision vector, without needing casting.
Public operatorStatic memberInequality
Determines whether two vectors have different values.
Public operatorStatic memberLessThan
Determines whether the first specified vector comes before (has inferior sorting value than) the second vector.

Components evaluation priority is first X, then Y, then Z.

Public operatorStatic memberLessThanOrEqual
Determines whether the first specified vector comes before (has inferior sorting value than) the second vector, or it is equal to it.

Components evaluation priority is first X, then Y, then Z.

Public operatorStatic memberMultiply(Double, Vector3d)
Multiplies a vector by a number, having the effect of scaling it.
Public operatorStatic memberMultiply(Vector3d, Vector3d)
Multiplies two vectors together, returning the dot product (or inner product). This differs from the cross product.
Public operatorStatic memberMultiply(Vector3d, Double)
Multiplies a vector by a number, having the effect of scaling it.
Public operatorStatic memberSubtraction
Subtracts the second vector from the first one.
Public operatorStatic memberUnaryNegation
Computes the opposite vector.
Top
See Also