Click or drag to resize

Vector3dMultiply Operator (Vector3d, Vector3d)

Multiplies two vectors together, returning the dot product (or inner product). This differs from the cross product.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public static double operator *(
	Vector3d vector1,
	Vector3d vector2
)

Parameters

vector1
Type: Rhino.GeometryVector3d
A vector.
vector2
Type: Rhino.GeometryVector3d
A second vector.

Return Value

Type: Double
A value that results from the evaluation of v1.X*v2.X + v1.Y*v2.Y + v1.Z*v2.Z.

This value equals v1.Length * v2.Length * cos(alpha), where alpha is the angle between vectors.

See Also