Click or drag to resize

Vector2d Operators

The Vector2d type exposes the following members.

Operators
  NameDescription
Public operatorStatic memberAddition
Sums up two vectors.
Public operatorStatic memberDivision
Divides a Vector2d by a number, having the effect of shrinking it.
Public operatorStatic memberEquality
Determines whether two vectors have equal values.
Public operatorStatic memberGreaterThan
Determines whether the first specified vector comes after (has superior sorting value than) the second vector.

Components have decreasing evaluation priority: first X, then Y.

Public operatorStatic memberGreaterThanOrEqual
Determines whether the first specified vector comes after (has superior sorting value than) the second vector, or it is equal to it.

Components have decreasing evaluation priority: first X, then Y.

Public operatorStatic memberInequality
Determines whether two vectors have different values.
Public operatorStatic memberLessThan
Determines whether the first specified vector comes before (has inferior sorting value than) the second vector.

Components have decreasing evaluation priority: first X, then Y.

Public operatorStatic memberLessThanOrEqual
Determines whether the first specified vector comes before (has inferior sorting value than) the second vector, or it is equal to it.

Components have decreasing evaluation priority: first X, then Y.

Public operatorStatic memberMultiply(Double, Vector2d)
Multiplies a vector by a number, having the effect of scaling it.
Public operatorStatic memberMultiply(Vector2d, Vector2d)
Multiplies two vectors together, returning the dot product (or inner product).
Public operatorStatic memberMultiply(Vector2d, Double)
Multiplies a vector by a number, having the effect of scaling it.
Public operatorStatic memberSubtraction
Subtracts the second vector from the first one.
Public operatorStatic memberUnaryNegation
Computes the opposite vector.
Top
See Also