Click or drag to resize

Interval Methods

The Interval type exposes the following members.

Methods
  NameDescription
Public methodCompareTo
Compares this Interval with another interval.

The lower bound has first evaluation priority.

Public methodEpsilonEquals
Check that all values in other are within epsilon of the values in this
Public methodEquals(Interval)
Determines whether the specified Interval is equal to the current Interval, comparing by value.
Public methodEquals(Object)
Determines whether the specified Object is equal to the current Interval, comparing by value.
(Overrides ValueTypeEquals(Object).)
Public methodStatic memberFromIntersection
Returns a new Interval that is the Intersection of the two input Intervals.
Public methodStatic memberFromUnion
Returns a new Interval which contains both inputs.
Public methodGetHashCode
Computes the hash code for this Interval object.
(Overrides ValueTypeGetHashCode.)
Public methodGrow
Grows the Interval to include the given number.
Public methodIncludesInterval(Interval)
Tests another interval for Interval inclusion.
Public methodIncludesInterval(Interval, Boolean)
Tests another interval for Interval inclusion.
Public methodIncludesParameter(Double)
Tests a parameter for Interval inclusion.
Public methodIncludesParameter(Double, Boolean)
Tests a parameter for Interval inclusion.
Public methodMakeIncreasing
Ensures this Interval is either singleton or increasing.
Public methodNormalizedIntervalAt
Converts interval value, or pair of values, to normalized parameter.
Public methodNormalizedParameterAt
Converts interval value, or pair of values, to normalized parameter.
Public methodParameterAt
Converts normalized parameter to interval value, or pair of values.
Public methodParameterIntervalAt
Converts normalized parameter to interval value, or pair of values.
Public methodReverse
Changes interval to [-T1, -T0].
Public methodSwap
Exchanges T0 and T1.
Public methodToString
Returns a string representation of this Interval.
(Overrides ValueTypeToString.)
Top
See Also