Click or drag to resize

IntervalCompareTo Method

Compares this Interval with another interval.

The lower bound has first evaluation priority.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public int CompareTo(
	Interval other
)

Parameters

other
Type: Rhino.GeometryInterval
The other Interval to compare with.

Return Value

Type: Int32

0: if this is identical to other

-1: if this[0] < other[0]

+1: if this[0] > other[0]

-1: if this[0] == other[0] and this[1] < other[1]

+1: if this[0] == other[0] and this[1] > other[1]

.

Implements

IComparableTCompareTo(T)
See Also