Click or drag to resize

QuaternionDistance Method

Returns the distance or norm of the difference between two quaternions.

Namespace:  Rhino.Geometry
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public static double Distance(
	Quaternion p,
	Quaternion q
)

Parameters

p
Type: Rhino.GeometryQuaternion
A quaternion.
q
Type: Rhino.GeometryQuaternion
Another quaternion.

Return Value

Type: Double
(p - q).Length()
See Also