Click or drag to resize

QuaternionGetRotation Method

Overload List
  NameDescription
Public methodGetRotation(Plane)
Returns the frame created by applying the quaternion's rotation to the canonical world frame (1,0,0),(0,1,0),(0,0,1).
Public methodGetRotation(Transform)
Returns a transformation matrix that performs the rotation defined by the quaternion. The transformation returned by this method has the property that xform * V = q.Rotate(V). If the quaternion is not unitized, the rotation of its unitized form is returned.
Public methodGetRotation(Double, Vector3d)
Returns the rotation defined by the quaternion.
Top
See Also