Click or drag to resize

QuaternionRotation Method

Overload List
  NameDescription
Public methodStatic memberRotation(Double, Vector3d)
Returns the unit quaternion cos(angle/2), sin(angle/2)*x, sin(angle/2)*y, sin(angle/2)*z where (x,y,z) is the unit vector parallel to axis. This is the unit quaternion that represents the rotation of angle about axis.
Public methodStatic memberRotation(Plane, Plane)
Returns the unit quaternion that represents the rotation that maps plane0.xaxis to plane1.xaxis, plane0.yaxis to plane1.yaxis, and plane0.zaxis to plane1.zaxis.
Top
See Also