Click or drag to resize

IntersectionPlaneBoundingBox Method

Intersects a plane and a bounding box.

Namespace:  Rhino.Geometry.Intersect
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 8.0
Syntax
public static bool PlaneBoundingBox(
	Plane plane,
	BoundingBox boundingBox,
	out Polyline polyline
)

Parameters

plane
Type: Rhino.GeometryPlane
The plane.
boundingBox
Type: Rhino.GeometryBoundingBox
The bounding box.
polyline
Type: Rhino.GeometryPolyline
The output polyline if successful.

Return Value

Type: Boolean
True if successful, false otherwise.
Remarks
Intersects the four bounding box infinite lines in the direction of the max coordinate with the plane. Point and single line intersections are ignored.
See Also