Click or drag to resize

IntersectionCircleCircle Method

Intersects two circles using exact calculations.

Namespace:  Rhino.Geometry.Intersect
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 7.12
Syntax
public static CircleCircleIntersection CircleCircle(
	Circle circleA,
	Circle circleB,
	out Point3d intersectionPoint1,
	out Point3d intersectionPoint2
)

Parameters

circleA
Type: Rhino.GeometryCircle
First circle to intersect.
circleB
Type: Rhino.GeometryCircle
Second circle to intersect.
intersectionPoint1
Type: Rhino.GeometryPoint3d
First intersection point.
intersectionPoint2
Type: Rhino.GeometryPoint3d
Second intersection point.

Return Value

Type: CircleCircleIntersection
The intersection type.
See Also