IntersectionMeshMeshPredicate Method |
Determines if meshes intersect or overlap.
Namespace:
Rhino.Geometry.Intersect
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 8.0
Syntax public static bool MeshMeshPredicate(
IEnumerable<Mesh> meshes,
double tolerance,
out int[] pairs,
TextLog textLog
)
Public Shared Function MeshMeshPredicate (
meshes As IEnumerable(Of Mesh),
tolerance As Double,
<OutAttribute> ByRef pairs As Integer(),
textLog As TextLog
) As Boolean
Parameters
- meshes
- Type: System.Collections.GenericIEnumerableMesh
The mesh input list. This cannot be null. Null entries are tolerated. - tolerance
- Type: SystemDouble
A tolerance value. If negative, the positive value will be used.
WARNING! Good tolerance values are in the magnitude of 10^-7, or RhinoMath.SqrtEpsilon*10. - pairs
- Type: SystemInt32
An array containing pairs of meshes that intersect. - textLog
- Type: Rhino.FileIOTextLog
A text log, or null.
Return Value
Type:
BooleanTrue, if meshes intersect or overlap, otherwise false. False is also returned on error, but textLog will start with Error: and contain the error.
See Also