Click or drag to resize

IntersectionLinePlane Method

Intersects a line and a plane. This function only returns true if the intersection result is a single point (i.e. if the line is coincident with the plane then no intersection is assumed).

Namespace:  Rhino.Geometry.Intersect
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public static bool LinePlane(
	Line line,
	Plane plane,
	out double lineParameter
)

Parameters

line
Type: Rhino.GeometryLine
Line for intersection.
plane
Type: Rhino.GeometryPlane
Plane to intersect.
lineParameter
Type: SystemDouble
Parameter on line where intersection occurs. If the parameter is not within the {0, 1} Interval then the finite segment does not intersect the plane.

Return Value

Type: Boolean
true on success, false on failure.
See Also