Click or drag to resize

IntersectionCurveLine Method

Intersects a curve and an infinite line.

Namespace:  Rhino.Geometry.Intersect
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 6.0
Syntax
public static CurveIntersections CurveLine(
	Curve curve,
	Line line,
	double tolerance,
	double overlapTolerance
)

Parameters

curve
Type: Rhino.GeometryCurve
Curve for intersection.
line
Type: Rhino.GeometryLine
Infinite line to intersect.
tolerance
Type: SystemDouble
Intersection tolerance. If the curves approach each other to within tolerance, an intersection is assumed.
overlapTolerance
Type: SystemDouble
The tolerance with which the curves are tested.

Return Value

Type: CurveIntersections
A collection of intersection events.
See Also