Click or drag to resize

CurveIntersections Class

Maintains an ordered list of Curve Intersection results.
Inheritance Hierarchy
SystemObject
  Rhino.Geometry.IntersectCurveIntersections

Namespace:  Rhino.Geometry.Intersect
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class CurveIntersections : IDisposable, 
	IList<IntersectionEvent>, ICollection<IntersectionEvent>, IEnumerable<IntersectionEvent>, 
	IEnumerable

The CurveIntersections type exposes the following members.

Properties
  NameDescription
Public propertyCount
Gets the number of recorded intersection events.
Public propertyItem
Gets the intersection event data at the given index.
Top
Methods
  NameDescription
Public methodCopyTo
Copies all intersection results into another array, departing at an index in the target array.
Public methodDispose
Actively reclaims unmanaged resources that this instance uses.
Protected methodDispose(Boolean)
For derived class implementers.

This method is called with argument true when class user calls Dispose(), while with argument false when the Garbage Collector invokes the finalizer, or Finalize() method.

You must reclaim all used unmanaged resources in both cases, and can use this chance to call Dispose on disposable fields if the argument is true.

Also, you must call the base virtual method within your overriding method.

Protected methodFinalize
Destructor.
(Overrides ObjectFinalize.)
Public methodGetEnumerator
Returns an enumerator that is capable of yielding all IntersectionEvents in the collection.
Top
See Also