Click or drag to resize

CurveIntersectionsCopyTo Method

Copies all intersection results into another array, departing at an index in the target array.

Namespace:  Rhino.Geometry.Intersect
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public void CopyTo(
	IntersectionEvent[] array,
	int arrayIndex
)

Parameters

array
Type: Rhino.Geometry.IntersectIntersectionEvent
The target array. This value cannot be null.
arrayIndex
Type: SystemInt32
Zero-based index in which to start the copy.

Implements

ICollectionTCopyTo(T, Int32)
Exceptions
ExceptionCondition
ArgumentNullExceptionIf array is null.
ArgumentOutOfRangeExceptionIf arrayIndex is less than 0.
ArgumentExceptionIf array is multi-dimensional; or if arrayIndex is larger than or equal to the length of this collection; or this collection contains more IntersectionEvents than the ones that can be stored in array after and including arrayIndex.
See Also